All services are fully operational. Thank you for your patience and understanding during this incident.
If you have any questions or concerns, please contact Exabeam Technical Support.
Posted Apr 11, 2026 - 16:37 UTC
Update
We are pleased to inform that we have deployed the fix and it is working as expected and we are recovering. All apps are healthy and functional.
We apologize for any inconvenience. If you have any questions or concerns, please contact Exabeam Technical Support.
Posted Apr 11, 2026 - 16:11 UTC
Update
We are pleased to inform that we have deployed the fix and it is working as expected. All apps are healthy and functional.
We apologize for any inconvenience. If you have any questions or concerns, please contact Exabeam Technical Support.
Posted Apr 11, 2026 - 15:06 UTC
Identified
We have received reports of a potential service degradation in Processing Stats dashboard in Service Health & Consumption application where that data shown may be incorrect. We have identified the issue and the fix and it will be rolled out shortly. We will update as soon as we make progress on the fix.
We apologize for any inconvenience. If you have any questions or concerns, please contact Exabeam Technical Support.
Posted Apr 11, 2026 - 13:01 UTC
This incident affected: australia-southeast1 (Australia) (Service Health and Consumption Dashboard), europe-west3 (Germany) (Service Health and Consumption Dashboard), northamerica-northeast1 (Canada) (Service Health and Consumption Dashboard), us-east1 (USA) (Service Health and Consumption Dashboard), us-west1 (USA) (Service Health and Consumption Dashboard), europe-west6 (Switzerland) (Service Health and Consumption Dashboard), and europe-west2 (London) (Service Health and Consumption Dashboard).