Search | Degraded Performance | US East

Incident Report for Exabeam

Resolved

This issue has been resolved, Search app is fully functional.
Posted Jul 18, 2025 - 18:26 UTC

Identified

The issue has been identified as being a vendor related incident. We are seeing recovery happen in most impacted environments, but we are still investigating for any residual impact. We will provide another update once we have believe the issue is fully resolved.
Posted Jul 18, 2025 - 17:52 UTC

Investigating

We are investigating an issue causing degraded performance in Search app for the US East region. You may experience the application being intermittently slow or inaccessible during this time. We apologize for the inconvenience and we are working to fix this as soon as possible. We will provide an update as more information is made available.
Posted Jul 18, 2025 - 16:05 UTC
This incident affected: us-east1 (USA) (Search).