USW1 region- ECP page is getting error "No Healthy Upstream"

Incident Report for Exabeam

Resolved

All services are fully operational. ECP pages are accessible.

Thank you for your patience and understanding during this incident. If you have any questions or concerns, please contact Exabeam Technical Support.
Posted Apr 28, 2026 - 10:09 UTC

Identified

We have identified the cause of the issue impacting Security Platform Operations. Our internal team is actively working on implementing a fix.

We appreciate your patience and will share further updates as soon as possible.

If you experience any issues or have further questions, please reach out to Exabeam Technical support.
Posted Apr 28, 2026 - 08:28 UTC
This incident affected: us-west1 (USA) (Security Operations Platform).