Thank you for your patience and understanding during this incident.
If you have any questions or concerns, please contact Exabeam Technical Support.
Posted Jun 17, 2026 - 13:49 UTC
Monitoring
The issue has been resolved, and Threat Center is functioning as expected. We are continuing to monitor the service to ensure stability and will keep you informed of any changes.
If you have any questions or concerns, please contact Exabeam Technical Support.
Posted Jun 17, 2026 - 09:56 UTC
Investigating
We are currently investigating reports of a potential service impact affecting Threat Center.
We apologize for any inconvenience and will provide an update as soon as additional information becomes available.
If you have any questions or concerns, please contact Exabeam Technical Support.
Posted Jun 17, 2026 - 09:12 UTC
This incident affected: europe-west3 (Germany) (Threat Center).