Dashboard is fully operational. We appreciate your patience and understanding. If you have any questions or concerns, please contact Exabeam technical support.
Posted Jul 19, 2025 - 01:10 UTC
Identified
Exabeam continues to work with the cloud vendor to remediate the issue. We apologize for any inconvenience. Next update to come as we gather more information.
Posted Jul 18, 2025 - 17:26 UTC
Update
We have raised a high priority case with our vendor to identify the issue. We apologize for any inconvenience. Next update to come as we gather more information.
Posted Jul 18, 2025 - 12:48 UTC
Update
We still continue to investigate the issue. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 18, 2025 - 10:42 UTC
Update
Our teams continues to investigate and fix the service. We apologize for any inconvenience. Next update to come as we gather more information.
Posted Jul 18, 2025 - 09:06 UTC
Investigating
We’re currently investigating reports of a potential service interruption with Dashboards. You may experience Dashboards not yielding results and showing the spinning wheel. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jul 18, 2025 - 07:49 UTC
This incident affected: me-central2 (KSA) (Dashboards).