Multiple Services: US East

Incident Report for Exabeam

Resolved

Services are fully operational. We appreciate your patience and understanding. If you have any questions or concerns, please contact Exabeam technical support.
Posted Sep 16, 2025 - 00:24 UTC

Investigating

We’re currently investigating reports of a potential service interruption. You may experience 'no healthy upstream' error on pages, including the Exabeam Cloud Platform landing page. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Sep 16, 2025 - 00:15 UTC
This incident affected: us-east1 (USA) (Correlation Rule Builder, Outcomes Navigator, Search, Security Operations Platform).