We are pleased to let you know that the scheduled maintenance for the Kubernetes cluster certificate in the us-west1 (USA) region has been completed successfully.
Thank you for your patience and cooperation. If you have any issues or questions, please contact Exabeam Technical Support.
Posted Jun 15, 2026 - 07:33 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jun 15, 2026 - 05:00 UTC
Scheduled
This is to inform you that we will be updating Kubernetes cluster certificate in the US-WEST1 region between June 15th 5:00 AM and June 15th 1:00 PM UTC.
The rolling update of certificate on all the nodes will continue in the background for a few days. This is a no-downtime activity and during this time window, you may experience brief service degradation which should recover automatically. We will provide periodic updates on the progress throughout the activity.
We appreciate your patience and co-operation as we work to maintain optimal performance. If you have any questions or concerns, please contact Exabeam Technical support.
Posted Jun 08, 2026 - 04:53 UTC
This scheduled maintenance affected: us-west1 (USA) (Security Operations Platform).