Search: US East

Incident Report for Exabeam

Resolved

Search is fully operational. We appreciate your patience and understanding. If you have any questions or concerns, please contact Exabeam technical support.
Posted Jun 20, 2025 - 19:41 UTC

Monitoring

Search is working as expected. We are continuously monitoring.
Posted Jun 20, 2025 - 19:34 UTC

Identified

Our team is currently working to restore the service.
Posted Jun 20, 2025 - 19:24 UTC

Investigating

We’re currently investigating reports of a potential service interruption with Search for customers in US East region. You may experience 'upstream request timeouts'. We apologize for any inconvenience and will post another update as soon as we learn more.
Posted Jun 20, 2025 - 18:57 UTC
This incident affected: us-east1 (USA) (Search).